Build problem with SocketW

earnest

New member
Joined
Sep 15, 2018
Messages
8
#1
Yesterday I tried to build RoR on Linux. There were crashes and problems, so I decided to build from the most recent versions of OGRE, etc...

Overnight, the build procedure on the GitHub wiki apparently has changed, and now a conan + ninja type of build is proposed.

I tried this, but linking fails:
undefined reference to `SWBaseSocket::SWBaseError::get_error[abi:cxx11]()

Still, libSocketW.a is linked in:
... /home/earnest/.conan/data/SocketW/3.10.36/anotherfoxguy/stable/package/fe848316b8ad30bac4dc1e2d5945e4231fba5abd/lib/libSocketW.a ...

and seems to contain get_error:
nm -a /home/earnest/.conan/.../libSocketW.a
0000000000000000 t .text._ZN12SWBaseSocket9get_errorEv
0000000000000090 T _ZN12SWBaseSocket11SWBaseError9get_errorEv
0000000000000000 W _ZN12SWBaseSocket9get_errorEv
0000000000000000 t .text._ZN12SWBaseSocket9get_errorEv
0000000000000000 W _ZN12SWBaseSocket9get_errorEv
U ERR_get_error
U SSL_get_error
0000000000000000 t .text._ZN12SWBaseSocket9get_errorEv
U _ZN12SWBaseSocket11SWBaseError9get_errorEv
0000000000000000 W _ZN12SWBaseSocket9get_errorEv
0000000000000000 t .text._ZN12SWBaseSocket9get_errorEv
0000000000000000 W _ZN12SWBaseSocket9get_errorEv

I'm puzzled. Can anyone help me out ?

Thanks


E.
 

AnotherFoxGuy

Developer
Developer
Joined
Jan 14, 2018
Messages
10
#2
Just tried building on Ubuntu 16.04, and I also have this issue.
For some reason, it doesn't occur on Travis

I will try and fix it ASAP
 
Last edited:
OP
OP
E

earnest

New member
Joined
Sep 15, 2018
Messages
8
#3
If it helps, I built SocketW separately, and copied the resulting libSocketW.a into the conan package dir. That links. I'll have a look at the differences of the 2 ar files.

Just tried building on Ubuntu 16.04, and I also have this issue.
For some reason, it doesn't occur on Travis

I will try and fix it ASAP
 
OP
OP
E

earnest

New member
Joined
Sep 15, 2018
Messages
8
#5
Fix is confirmed. It now builds properly.

Thanks for helping !
(Still having OGRE issues, though. Caelum does not work at all and the entire terrain is textureless. Vehicles are mostly ok, but, e.g. not the ship in the default terrain.)


E.
 
Top