Results 1 to 3 of 3

Thread: no traction in most vehicles

  1. #1

    Join Date
    Feb 2018
    Location
    Readsboro, VT(the place i love) Florida, MA(the place i hate)
    Posts
    13
    Slovak Republic

    no traction in most vehicles

    i have noticed while driving vehicles that most will spin out very easily. is there something i can change about the game to help prevent these frequent spin outs? or do i just need to get used to it.

  2. #2
    akaikitty's Avatar
    Join Date
    May 2018
    Location
    s o m e w h e r e
    Posts
    166
    UK

    Re: no traction in most vehicles

    You're probably using rear wheel drive vehicles by the sounds of things. I have solutions and a fix that completely helps but requires modding the Car's .truck file.

    This is solved with a controller or wheel. There should be input.maps for them in the Repo archive. I used an xbox 360 controller and that worked pretty well for RWD cars. Or make your own .map yourself- Controls and configuration -, see the 'Config File Input.map' section.

    Be easy on the accelerator. You wouldn't slam the gas down in a muscle car with no safety measurements, nor a dangerous race car. Especially with RoR's engine. This is solved with a controller or wheel.

    Or, to 'fix' this, you'll have to make the cars 4 wheel drive. Go to the car's zip file, and open the .truck file. We'll be using the bmw e36 as an example, but this should work for other cars.

    Open the .truck file with your text editor, I'm using notepad++ but notepad will do. I.e e36.truck

    Find 'Meshwheels', 'wheels', or 'flexbodywheels'.

    You should see this section:

    Code:
    meshwheels2
    ;tire_radius, rim_radius,width,numrays,node1,node2,snode,braked,propulsed, arm, mass, spring, damping, side, meshname material
    0.34, 0.25, 0.3,14,119,121,9999,4,0,101,46,145000,1200, l, E36LW_Frim.mesh gavrilinvis
    0.34, 0.25, 0.3,14,120,122,9999,4,0,105,46,145000,1200, r, E36LW_Frim.mesh gavrilinvis
    
    
    set_node_defaults -1, 1.06, -1, -1
    set_beam_defaults 2200000,  100,  2500000,  3000000, 0.02, gavrilinvis, 0.0
    ;;rear
    0.34, 0.25, 0.3,14,135,137,9999,1,1,57,46,145000,1200, l, E36LW_Rrim.mesh gavrilinvis
    0.34, 0.25, 0.3,14,136,138,9999,1,1,61,46,145000,1200, r, E36LW_Rrim.mesh gavrilinvis
    You'll see the code for the wheels here.

    Note that the 9th column says '1' on the rear wheels. This tells the game where torque is applied to the wheels.

    Note that this isn't on the front wheels.

    Now, next to '4', after '9999' and before '111', You'll want to change both 0's to 1. This changes the car to 4wd.

    You'll have to do this to every individual car you can't control.

    Or, you can add traction control, but it doesn't work completely effectively.

    So, it should now look like:

    Code:
    meshwheels2
    ;tire_radius, rim_radius,width,numrays,node1,node2,snode,braked,propulsed, arm, mass, spring, damping, side, meshname material
    0.34, 0.25, 0.3,14,119,121,9999,4,1,101,46,145000,1200, l, E36LW_Frim.mesh gavrilinvis
    0.34, 0.25, 0.3,14,120,122,9999,4,1,105,46,145000,1200, r, E36LW_Frim.mesh gavrilinvis
    
    
    set_node_defaults -1, 1.06, -1, -1
    set_beam_defaults 2200000,  100,  2500000,  3000000, 0.02, gavrilinvis, 0.0
    ;;rear
    0.34, 0.25, 0.3,14,135,137,9999,1,1,57,46,145000,1200, l, E36LW_Rrim.mesh gavrilinvis
    0.34, 0.25, 0.3,14,136,138,9999,1,1,61,46,145000,1200, r, E36LW_Rrim.mesh gavrilinvis
    Now, the car should handle easier. This isn't as realistic, and not the way the vehicle dev's intended.

    Hope this helped.
    Last edited by akaikitty; 05-14-2018 at 06:44 PM. Reason: Added and cleaned up
    Basic bitch, 7 years into the game and still hasn't figured out most of an n/b yet.

    Thinpad T410, i5 560m, 8gb ram. Blazing speed.

    They/She. I can't think of an enby N/B pun, thank christ.

    Submesh agora skins don't show off the game, neither do the countless schoolbus roleplays.

    We need more spider-robot things. That was a thing in like 0.2x. Come on /s



  3. #3

    Re: no traction in most vehicles

    Or, you could navigate to C:\Users\...\Documents\Rigs of Rods 0.4\config, open RoR.cfg in a text editor, and add the line:

    HighResWheelNodeCollisions=Yes

    Somewhere in that file; Assuming you are using 0.4.6.0+
    no traction in most vehicles-5keipzd-png

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •