Solved no AI in rigs of rods .4.8.0 Release Canidate 4

h12345

New member
Joined
Dec 25, 2018
Messages
13
I downloaded the ai test maps in rigs of rods .4.8.0 RC4 (latest development version), & the ai won't work.
4018



4020
 
OP
OP
h12345

h12345

New member
Joined
Dec 25, 2018
Messages
13
4BusFollow.as (41, 1): Info = Compiling void frameStep(float)
4BusFollow.as (54, 13): Warning = The operand is implicitly converted to handle in order to compare them
4BusFollow.as (68, 13): Error = No matching signatures to 'BeamClass::navigateTo(vector3&)'
4BusFollow.as (78, 13): Error = No matching signatures to 'BeamClass::navigateTo(vector3&)'
4BusFollow.as (88, 13): Error = No matching signatures to 'BeamClass::navigateTo(vector3&)'
4BusFollow.as (98, 13): Error = No matching signatures to 'BeamClass::navigateTo(vector3&)'
Failed to build the module
Executing main()
default terrain script loaded
The script finished successfully.
 

CuriousMike

Repository Manager
Administrator
Old-timer
Joined
Dec 22, 2018
Messages
845
Location
Florida
4BusFollow.as used an old version of the waypoint AI, the AI code got rewritten later. Examples of the new AI can be found on the Bajarama V2 and F1 Test Track terrains.
 
OP
OP
h12345

h12345

New member
Joined
Dec 25, 2018
Messages
13
4BusFollow.as used an old version of the waypoint AI (designed for 0.4.0.0/0.4.6.0), the AI code got rewritten later (for RoR 0.4.7.0/0.4.8.0). Examples of the new AI can be found on the Bajarama V2 and F1 Test Track terrains.
ah, ok thanks, man. I thought it was just my computer. (or the fact that I am running it on a chromebook) but I managed to get the ai working in the standard AITestMap.terrn2. I wish I can show y'all a video of the ai running in anotherfoxguy's AITestMap.terrn2, but this forum wouldn't accept .mp4 files.
 
Last edited:
Top