RoR on the raspberry pi 4

rpi-user

New member
Joined
Feb 23, 2021
Messages
5
I have a raspberry pi 4 4gb running 64 bit raspbian, the snap store says that it works, but when I run a world, it crashes at 15% and said "
FATAL ERROR: An internal error occured in Rigs of Rods.

Technical details below:

InvalidParametersException: This pass does not have this program type assigned! in getGpuProgramParameters at /build/rigs-of-rods/parts/ogre/src/OgreMain/src/OgrePass.cpp (line 1340)

", I would like to get this working to add to my small catalog of games that I can actually run, please help
 
OP
OP
R

rpi-user

New member
Joined
Feb 23, 2021
Messages
5
I like to mess around with the pi, And RoR seems like like a fun challenge, as well as flightgear has no soft body physics on most planes
 

atv_123

Member
Joined
Jun 15, 2007
Messages
35
Location
Pennsylvania
Hmmmmm....

This looks like a similar error that I got when I tried to run RoR on a Gateway Laptop a long long long time ago. Basically the issue (or at least my issue) was that the GPU that was in the computer didn't have the capability to render 3D graphics... or at least... not in the normal modern sense. Very very old stuff like Quake or Doom that used cheaty methods of doing 3D did run, but anything that actually tried to use actual 3D would not boot. The only game that used actual 3D that I actually got to run on the thing was NFS High Stakes... which is ironic considering for the hardware, that should have been a fairly demanding game.

But yeah... the laptop was basically ancient technology even then. It had a 233MHz processor from a Pentium 2? and I think like... 97Mbs of ram. I don't even know why I bothered trying, but I did anyways.

That's my guess though... more than likely if you want to run it your going to need a graphics card of some sort... even a pathetic one should be enough to get you a few frames. The lowest end hardware I ever got it to run on was like 700~ MHz and 128MBs of ram on some old IBM think station or something. I don't totally remember what it was called.
 

4x4convoy

4 Link The World
Moderator
Joined
Jan 12, 2018
Messages
216
Location
Pennsylvania
if its crashing when trying to load a terrain then you're probably having issues with ogre, which is what your error says. ogre probably cant run on a pi
 
Top