DeGa Mountain Road

DeGa Mountain Road 1.1

I got an issue with this map, seems uniqe to this map.
Recent 2024.01-dev build on Debian 12, OpenGL, amdgpu.

Terrain has gone way below. And is also darker, no textures, but this happens on many maps.
I can drive on road but it's also invisible.
I went as person over road fence and then started falling, after a while I was on that terrain which is completely flat, and I can go or drive there too.
Seems like an issue with heightmap or such?
Anyone has it too or knows how to fix?
 

Attachments

  • 07_15-27-38`.jpg
    07_15-27-38`.jpg
    119.6 KB · Views: 31
  • 07_15-42-45`.jpg
    07_15-42-45`.jpg
    180.5 KB · Views: 23
  • 07_18-42-01`.jpg
    07_18-42-01`.jpg
    81.1 KB · Views: 25
I got an issue with this map, seems uniqe to this map.
Recent 2024.01-dev build on Debian 12, OpenGL, amdgpu.

Terrain has gone way below. And is also darker, no textures, but this happens on many maps.
I can drive on road but it's also invisible.
I went as person over road fence and then started falling, after a while I was on that terrain which is completely flat, and I can go or drive there too.
Seems like an issue with heightmap or such?
Anyone has it too or knows how to fix?
This terrain is completely meshed, no heightmap is used. It's using an alpha splatting shader that fails to compile on OpenGL with AMD GPUs:

Code:
13:46:02: RenderingAPIException: 'ETAmbient_VS' line 20, char 17: error: syntax error, unexpected MASK1
 in loadFromSource at /home/runner/.conan/data/ogre3d/1.11.6.1/anotherfoxguy/stable/build/903c00ec8d35ce5ab10af8d16b5a99a73d6ee4d0/RenderSystems/GL/src/OgreGLGpuProgram.cpp (line 188)

Looks like I'll have to replace this one with a simpler alpha splatting material that doesn't require Cg.

This problem is also present on RoR Compound, ashes48's terrains, and with the road borders on Badlands Rally:
20240217140207_1.jpg
 
Last edited:
Great. It works now.
Wow awesome track. And it doesn't even use terrain with LODs, just big meshes.
 
Last edited:
Back
Top