Released Improved RoR particles (Tire smoke, Sparks, Engine Smoke)

Charger

Branding Designer
Moderator
Old-timer
Joined
Jan 22, 2011
Messages
174
Location
Texas
You may have noticed that particles, things like tire smoke, sparks, engine smoke, water splashes, etc have never worked quite right in RoR, and had even gotten worse in newer versions. Well a while back I decided to take a look at them and try to rework the worst ones so they're not only way nicer to look at, but much more realistic as well. These are the results of my tinkering.

The largest amount of credit goes to Pricorde and any RoR contributors who have dealt with particles for giving me the base system to work with.





Instructions:

Extract ImprovedRoRParticles.zip to your preferred location, copy contents of extracted folder to C:\Program Files (x86)\Rigs of Rods 0.4.7.0\resources\particles.zip, then run RoR! It's as simple as that.


screenshot_2018-07-09_22-27-46_1.pngscreenshot_2018-07-09_22-28-24_1.pngscreenshot_2018-07-09_22-28-29_1.pngscreenshot_2018-07-09_22-28-34_1.pngscreenshot_2018-07-09_22-29-14_1.pngscreenshot_2018-07-10_00-08-00_1.pngscreenshot_2018-07-10_00-08-13_1.pngscreenshot_2018-07-10_00-09-54_1.pngscreenshot_2018-07-09_23-36-27_1.png





Enjoy!
 

Attachments

Last edited:
OP
OP
Charger

Charger

Branding Designer
Moderator
Old-timer
Joined
Jan 22, 2011
Messages
174
Location
Texas
They should theoretically work in all versions of RoR.
 
M

Michael10055

Guest
You need to copy particles.zip to the Desktop, copy the contents of the downloaded zip to the copied particles.zip, then move it back into resources.

Or you can redownload the 0.4.7.0 setup as these particles are now included with it. :)
 

dwink

New member
Joined
Jan 14, 2018
Messages
9
I moved the content over, and now I keep getting an error message. it says particle system with name tracks/ dust already exist. I tried deleting the file then it gives me an error message for a different file name in that folder. I redownloaded the set up you provided and ran it. Still gives me the same error message when trying to launch the game.
 
Top