What Was the First Mod you Tried in Rigs of Rods?

Gavril G2R on North St. Helens. (I had just found out about the game while searching for a free BeamNG.drive alternative. I didn't want to download the 2GB content packs so I got one map and one modpack, The G2 series, in case the deformation of stuff was crappy. It didn't disappoint, however. 😄)
Last edited:
Mine was the DAF. I first got the game when I was looking for something to play that was free and good. I wanted BeamNG, but I was a Freshman in high school. I also only had a school-issued laptop, so it had to be somewhat light. I was SUMPREMELY clueless when it came to the game, but I figured out how to installed mods. Once I did, Neo-Queretaro and the Volvo VNL were my faves.
Probably one of the DAFs, on Flat Map. Back in March, after years of mid-end consumer PCs, I finally got something that would be a halfway decent gaming PC (Lenovo Creator 5i) with a halfway decent graphics card (Nvidia 1660TX SUPER) and processor (10th gen Intel i5). The problem is that I had to only end up with just 12GB of RAM, which isn't good for anything.

Except I didn't realize until after I got it that it was a space saver model with a laptop board, and unlike a workstation, everything is crammed in tight. It came with 12GB of RAM; and can take 64; but I have to take half the darn stuff out. The drives and the fan are on top of the are where the RAM cards clip in.
Gavril zeta 2WD at the Auriga proving ground.
It's not a picture from that time... but I was playing stupid like this. screenshot_2023-02-04_06-51-21_1.pngscreenshot_2023-02-04_06-51-41_1.pngscreenshot_2023-02-04_06-51-47_1.pngscreenshot_2023-02-04_06-55-19_1.png
Last edited:
I first used an old Rigs of Rods big rig on North St Helens. I hardly knew how to run the truck so I got rid of the game and now about a year ago I finally realized what this game is about and I love it!
The very first mod I tried was the Gavril G2 in Penguinville, if I recall correctly.
Gavril omega and the oval track, i drove like a dumbass at the time. didnt know how to change gears, so i just pulled it with the cursor.